What to do if the "Convert to APFS..." option is not available or greyed out?
I started up the Disk Utility and tried to Erase the disc and make it HFS+, then convert it to APFS. But after I get HFS+ I noticed that the “Convert to APFS…” option is for some reason deactivated. It is visible but it is greyed out and can not be selected.
What I have:
- Drive: Transcend StoreJet 25M3 1Tb
- OS: macOS High Sierra 10.13.3
What causes this issue
This is not a Transcend issue. It can happen with a disc from any manufacturer. But this is not a problem with the disc at all. It’s all about the brand new APFS file system. The Disk Utility app cannot convert to APFS as the volume is not HFS+ extended.
This may also be due to an update macOS to version 10.13.3 as before there was no such a problem. But this is only an assumption.
How to solve it
Critical! The instructions in the article below are designed to help repartition and format a hard drive. This process is data destructive and cannot be undone. Once the process begins, all the data on the drive will be lost!
Be careful working with disks in the terminal. Incorrect actions can lead to data loss and even computer failure.
To solve this issue, we will use the Terminal app and the two tools diskutil
and dd
. Both tools are built-in in macOS, so we do not need to download or install anything. First, we format the disk in the HFS+ in the Terminal app, and then convert the HFS+ into APFS using the Disk Utility app.
Launch the Terminal app from the Utilities folder of your Applications folder, or use Spotlight to find it.
Firstly we need to identify the mount name of our disk (hard drive):
diskutil list
/dev/disk0 (internal, physical): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *121.3 GB disk0 1: EFI EFI 209.7 MB disk0s1 2: Apple_APFS Container disk1 121.1 GB disk0s2 /dev/disk1 (synthesized): #: TYPE NAME SIZE IDENTIFIER 0: APFS Container Scheme - +121.1 GB disk1 Physical Store disk0s2 1: APFS Volume Macintosh HD 105.5 GB disk1s1 2: APFS Volume Preboot 21.0 MB disk1s2 3: APFS Volume Recovery 509.9 MB disk1s3 4: APFS Volume VM 3.2 GB disk1s4 /dev/disk2 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: FDisk_partition_scheme *1.0 TB disk2 1: Apple_HFS Transcend 1.0 TB disk2s1
There are two types of devices (methods to communicate with devices):
- raw devices
/dev/rdisk*
, communication is direct with the disk.- buffered devices
/dev/disk*
, data transit via buffer.When using
dd
or other duplication programs, always use raw device.
The below commands assume this is disk2
, but replace disk2
with the correct disk if it’s something different.
Before any operations on the disk we must unmount it:
diskutil unmountDisk force disk2
Forced unmount of all volumes on disk2 was successful
Warning! Do not forget to replace the
disk2
before pressing the key Enter.
Now we will write zeros to the disk (this will erase the entire disk):
sudo dd if=/dev/zero of=/dev/rdisk2 bs=1024 count=1024
Warning! Do not forget to replace the
rdisk2
before pressing the key Enter.
This command will prompt us to enter our computer password. Enter your password and then watch the magic happen…
Note! It’s normal that the password you enter is not displayed. This is how the password is entered on the command line. Just enter your password, and then press the Enter key.
Password: 1024+0 records in 1024+0 records out 1048576 bytes transferred in 2.448794 secs (428201 bytes/sec)
Let’s now partition the disk. This will be the GUID Partition Table (GPT) and the Journaled HFS+ format of file systeme:
diskutil partitionDisk disk2 GPT JHFS+ "Transcend" 0g
Started partitioning on disk2 Unmounting disk Creating the partition map Waiting for partitions to activate Formatting disk2s2 as Mac OS Extended (Journaled) with name Transcend Initialized /dev/rdisk2s2 as a 931 GB case-insensitive HFS Plus volume with a 81920k journal Mounting disk Finished partitioning on disk2 /dev/disk2 (external, physical): #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *1.0 TB disk2 1: EFI EFI 209.7 MB disk2s1 2: Apple_HFS Transcend 999.9 GB disk2s2
Note! Replace “Transcend” with the name that you want to give to your hard drive.
Note! To get Master Boot Record (MBR) instead of GUID Partition Table (GPT), simply replace the “GPT” mention to “MBR”. That should work.
Warning! Do not forget to replace the
disk2
before pressing the key Enter.
Looks good. Our brand new hard drive prepared for the APFS format.
Finally, we can use the Disk Utility app to convert our hard drive from HFS+ format to APFS format. You can read more in this article.
Conclusion
That’s it, you’re done. So simple isn’t it?
If you are having trouble fixing this problem with the instructions above, but are being able to solve this problem with any another method please describe it in the comment section below. Thanks!
If this article has helped you solve the problem then please leave a comment
Thanks for reading!
Arthur is a designer and full stack software engineer. He is the founder of Space X-Chimp and the blog My Cyber Universe. His personal website can be found at arthurgareginyan.com.